Investigating elevated verification errors
Incident Report for Cocotec
Resolved
This incident has been resolved.
Posted May 12, 2022 - 05:49 UTC
Investigating
We are currently investigating this issue.
Posted May 12, 2022 - 05:48 UTC
This incident affected: Verification API.