Investigating elevated verification errors
Incident Report for Cocotec
Resolved
This incident has been resolved.
Posted Oct 14, 2024 - 16:53 UTC
Investigating
We are currently investigating this issue.
Posted Oct 14, 2024 - 16:52 UTC
This incident affected: Verification API.