Investigating elevated verification errors
Incident Report for Cocotec
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 00:32 UTC
Investigating
We are currently investigating this issue.
Posted Jun 03, 2024 - 00:31 UTC
This incident affected: Verification API.