Investigating elevated verification errors
Incident Report for Cocotec
Resolved
This incident has been resolved.
Posted Jul 25, 2020 - 11:13 UTC
Investigating
We are currently investigating this issue.
Posted Jul 25, 2020 - 11:12 UTC
This incident affected: Verification API.