Investigating elevated website errors
Incident Report for Cocotec
Resolved
This incident has been resolved.
Posted Nov 15, 2023 - 18:41 UTC
Investigating
We are currently investigating this issue.
Posted Nov 15, 2023 - 18:37 UTC
This incident affected: Website.