Investigating elevated website errors
Incident Report for Cocotec
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 01:38 UTC
Investigating
We are currently investigating this issue.
Posted Feb 22, 2021 - 01:30 UTC
This incident affected: Website.