Investigating elevated verification errors

Incident Report for Cocotec

Resolved

This incident has been resolved.
Posted May 03, 2024 - 10:47 UTC

Investigating

We are currently investigating this issue.
Posted May 03, 2024 - 10:42 UTC
This incident affected: Verification API.