Investigating elevated verification errors
Incident Report for Cocotec
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 18:11 UTC
Investigating
We are currently investigating this issue.
Posted Nov 16, 2021 - 17:54 UTC
This incident affected: Verification API.