Investigating elevated verification errors
Incident Report for Cocotec
Resolved
This incident has been resolved.
Posted Aug 06, 2021 - 21:53 UTC
Investigating
We are currently investigating this issue.
Posted Aug 06, 2021 - 21:48 UTC
This incident affected: Verification API.