Investigating elevated verification errors

Incident Report for Cocotec

Resolved

This incident has been resolved.
Posted Jun 15, 2023 - 17:15 UTC

Investigating

We are currently investigating this issue.
Posted Jun 15, 2023 - 17:13 UTC
This incident affected: Verification API.