Investigating elevated verification errors
Incident Report for Cocotec
Resolved
This incident has been resolved.
Posted Sep 12, 2022 - 00:38 UTC
Investigating
We are currently investigating this issue.
Posted Sep 12, 2022 - 00:25 UTC
This incident affected: Verification API.